autstat Support

icon
Avatar
Piero Comino
Posts: 1
hello,
I'm trying to install SExcel but I have some problems with rcom and rscproxy.

I start R as administrator and:
options(install.packages.check.source = "no")
install.packages(c("rscproxy","rcom"),repos="http://<<repo-user>>:<<repo-password>>@www.autstat.com/r-repo",lib=.Library,type="win.binary")

and the result is:
Warning: unable to access index for repository http://<<my-username>>:<<my-password>>@www.autstat.com/r-repo/bin/windows/contrib/3.5:
impossibile aprire URL 'http://<<my-username>>:<<my-password>>@www.autstat.com/r-repo/bin/windows/contrib/3.5/PACKAGES'
Warning message:
packages ‘rscproxy’, ‘rcom’ are not available (as a binary package for R version 3.5.0)

can you help me please?


[1] "R version 3.5.0 (2018-04-23)"



R version 3.5.0 (2018-04-23)
Platform: i386-w64-mingw32/i386 (32-bit)
Running under: Windows 10 x64 (build 17134)

Matrix products: default

locale:
[1] LC_COLLATE=Italian_Italy.1252 LC_CTYPE=Italian_Italy.1252 LC_MONETARY=Italian_Italy.1252 LC_NUMERIC=C LC_TIME=Italian_Italy.1252

attached base packages:
[1] stats graphics grDevices utils datasets methods base

loaded via a namespace (and not attached):
[1] compiler_3.5.0 tools_3.5.0

> installed.packages()["rscproxy",]
Error in installed.packages()["rscproxy", ] : indice fuori limite

Error in installed.packages()["rscproxy", ] : indice fuori limite
> installed.packages()["rcom",]
Package LibPath Version
"rcom" "C:/Users/Utente/Documents/R/win-library/3.5" "1.2.4"
Priority Depends Imports
NA "R (>= 2.2.0)" NA
LinkingTo Suggests Enhances
NA NA NA
License License_is_FOSS License_restricts_use
"GPL Version 2 or later." NA NA
OS_type MD5sum NeedsCompilation
NA NA NA
Built
"c(2, 3, 0)"




set up test: Analyze System:
version <3.5.0>
Package <rscproxy> information for 32 Bit R could not be retrieved, probably not installed
============================================================
Package <rcom> for 32 Bit R is installed in <C:\Users\Utente\Documents\R\win-library\3.5>
Should be installed in <C:\Program Files\R\R-3.5.0\library>
============================================================
Package <rscproxy> information for 64 Bit R could not be retrieved, probably not installed
============================================================
Package <rcom> for 64 Bit R is installed in <C:\Users\Utente\Documents\R\win-library\3.5>
Should be installed in <C:\Program Files\R\R-3.5.0\library>
============================================================
statconnDCOM 32 Bit: 32bit version installed in <C:\Program Files (x86)\autstat\Excel\statconnDCOM>, current version <3.6-0B10>
statconnDCOM 64 Bit: not found

thank you.
2018-06-10 20:40
Avatar
Thomas Baier
Moderator
Posts: 174
Dear Piero,

rscproxy for R 3.5 requires an update to statconnDCOM. The package update will be available tomorrow or Wednesday together with a new installer for scExcel.

Best regards,
Thomas
2018-06-11 04:44
icon