autstat Support

icon
Avatar
larry_rave
Posts: 9
Good morning,

I have just downloaded from the repository rcom 3.1-5 which is supposed to be compatible with R 3.4. However, as I load the library, I get the error

Error: package ‘rcom’ was built before R 3.0.0: please re-install it

Am I doing anything wrong?

Thanks,

Larry
2017-11-02 10:41
Avatar
Thomas Baier
Moderator
Posts: 173
Please let us know, which repository you were using (the full command line for installing the package would be great).

Best regards.
Thomas
2017-11-02 11:01
Avatar
larry_rave
Posts: 9
Sure, here it is

install.packages(c("rscproxy","rcom"),repos="http://www.autstat.com/download",
lib=.Library,type="win.binary")

after which I get

trying URL 'http://www.autstat.com/download/bin/windows/contrib/3.4/rscproxy_2.1-3.zip'
Content type 'application/zip' length 70561 bytes (68 KB)
downloaded 68 KB

trying URL 'http://www.autstat.com/download/bin/windows/contrib/3.4/rcom_3.1-5.zip'
Content type 'application/zip' length 401522 bytes (392 KB)
downloaded 392 KB

package ‘rscproxy’ successfully unpacked and MD5 sums checked
package ‘rcom’ successfully unpacked and MD5 sums checked



I work under

R version 3.4.2 (2017-09-28) -- "Short Summer"
Copyright (C) 2017 The R Foundation for Statistical Computing
Platform: x86_64-w64-mingw32/x64 (64-bit)


Thanks,

Larry

p.s.

I'll be off for about a week, so no rush at all in taking a look at this...
2017-11-02 13:29
Avatar
Thomas Baier
Moderator
Posts: 173
Please try the following:

installed.packages()["rscproxy",]
installed.packages()["rcom",]

and post the output here
2017-11-02 13:55
Avatar
larry_rave
Posts: 9
I have just tried, that's what I get:


> installed.packages()["rscproxy",]
Package LibPath
"rscproxy" "C:/Users/lorenzo/Documents/R/win-library/3.4"
Version Priority
"2.0-5" NA
Depends Imports
NA NA
LinkingTo Suggests
NA NA
Enhances License
NA "GPL-2"
License_is_FOSS License_restricts_use
NA NA
OS_type MD5sum
NA NA
NeedsCompilation Built
NA "3.0.0"
> installed.packages()["rcom",]
Package LibPath
"rcom" "C:/Users/lorenzo/Documents/R/win-library/3.4"
Version Priority
"2.3-1" NA
Depends Imports
"R (>= 2.14.0), rscproxy (>= 2.0-1), utils" NA
LinkingTo Suggests
"rscproxy" NA
Enhances License
NA "file LICENSE"
License_is_FOSS License_restricts_use
NA NA
OS_type MD5sum
"windows" NA
NeedsCompilation Built
NA "2.15.1"
2017-11-09 09:26
Avatar
Thomas Baier
Moderator
Posts: 173
Sorry, you did not install into the global library directory. The command line you posted does not match the paths where rcom and rscproxy are installed. Maybe you did not run R as Administrator.

Please read http://autstat.com/index.php/Support/topic/3.html

For further support, please post to the appropriate support forum in "Diagnosing and Solving Installation Problems"

Best regards,
Thomas Baier
2017-11-09 13:21
Avatar
larry_rave
Posts: 9
Will do, thanks

Larry
2017-11-09 13:38
icon